eBGP route filter with EIGRP

 


Expectation:

  • R2 takes routes only with prefix 10.10.30.0/24
  • R2 Advertise the route to its iBGP neighbour r3
  • R2 redistributes its BGP routes to its EIGRP so that R5 can access 10.10.30.1 (R1's lo0)
Config Below:

R1


!

interface Loopback0

 ip address 10.10.30.1 255.255.255.0

!

interface Loopback1

 ip address 20.20.30.1 255.255.255.0

!

interface FastEthernet0/0

 ip address 20.20.20.2 255.255.255.0

 duplex auto

 speed auto

!

interface FastEthernet1/0

 no ip address

 shutdown

 duplex auto

 speed auto

!

router bgp 65515

 no synchronization

 bgp log-neighbor-changes

 redistribute connected

 neighbor 20.20.20.1 remote-as 65521

 no auto-summary

!



R2


!

interface Loopback0

 ip address 1.1.1.1 255.255.255.255

!

interface FastEthernet0/0

 ip address 20.20.20.1 255.255.255.0

 duplex auto

 speed auto

!

interface FastEthernet1/0

 ip address 10.10.10.1 255.255.255.0

 duplex auto

 speed auto

!

interface FastEthernet2/0

 ip address 10.10.21.1 255.255.255.0

 duplex auto

 speed auto

!

interface FastEthernet3/0

 no ip address

 shutdown

 duplex auto

 speed auto

!

router eigrp 100

 redistribute connected

 redistribute bgp 65521 metric 100 1 255 1 1500

 network 10.10.21.0 0.0.0.255

 auto-summary

!

router bgp 65521

 no synchronization

 bgp log-neighbor-changes

 redistribute connected

 redistribute eigrp 100

 neighbor 10.10.10.2 remote-as 65521

 neighbor 20.20.20.2 remote-as 65515

 neighbor 20.20.20.2 prefix-list ten in

 no auto-summary

!

ip prefix-list ten seq 5 permit 10.10.30.0/24

!


R3


!

interface Loopback0

 ip address 1.1.1.2 255.255.255.255

!

interface FastEthernet0/0

 no ip address

 shutdown

 duplex auto

 speed auto

!

interface FastEthernet1/0

 ip address 10.10.10.2 255.255.255.0

 duplex auto

 speed auto

!

interface FastEthernet2/0

 ip address 10.10.22.1 255.255.255.0

 duplex auto

 speed auto

!

interface FastEthernet3/0

 no ip address

 shutdown

 duplex auto

 speed auto

!

router eigrp 100

 redistribute connected

 redistribute bgp 65521

 network 10.10.22.0 0.0.0.255

 auto-summary

!

router bgp 65521

 no synchronization

 bgp log-neighbor-changes

 neighbor 10.10.10.1 remote-as 65521

 no auto-summary

!


R4


!

interface Loopback0

 ip address 1.1.1.3 255.255.255.255

!

interface FastEthernet0/0

 ip address 10.10.23.1 255.255.255.0

 duplex auto

 speed auto

!

interface FastEthernet1/0

 no ip address

 duplex auto

 speed auto

!

interface FastEthernet2/0

 ip address 10.10.21.2 255.255.255.0

 duplex auto

 speed auto

!

interface FastEthernet3/0

 no ip address

 shutdown

 duplex auto

 speed auto

!

router eigrp 100

 network 10.10.21.0 0.0.0.255

 network 10.10.23.0 0.0.0.255

 auto-summary

!


R5



!

interface Loopback0

 ip address 1.1.1.4 255.255.255.255

!

interface FastEthernet0/0

 ip address 10.10.23.2 255.255.255.0

 duplex auto

 speed auto

!

interface FastEthernet1/0

 no ip address

 duplex auto

 speed auto

!

interface FastEthernet2/0

 ip address 10.10.22.2 255.255.255.0

 duplex auto

 speed auto

!

interface FastEthernet3/0

 no ip address

 shutdown

 duplex auto

 speed auto

!

router eigrp 100

 network 10.10.22.0 0.0.0.255

 network 10.10.23.0 0.0.0.255

 auto-summary

!

Comments

Popular Posts